CVE-2022-23121 : netatalk - parse_entries Improper Handling of Exceptional Conditions Remote Code Execution

Versions Affected : All versions prior to TrueNAS Core 12.0-U8.1 To verify if a system is vulnerable, run afpd -v. Systems with a version string that is not 3.1.13 or newer are vulnerable.


This vulnerability allows remote attackers to execute arbitrary code on affected installations of Netatalk. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the parse_entries function. The issue results from the lack of proper error handling when parsing AppleDouble entries. An attacker can leverage this vulnerability to execute code in the context of root.


Base score


No workarounds available


  • Disable affected AFP shares until upgrade is possible
  • Upgrade to TrueNAS 12.0-U8.1


Further information

Back to CORE Archive