Versions Affected : All versions prior to TrueNAS Core 12.0-U8.1
To verify if a system isvulnerable, run
afpd -v. Systems with a version string that is not 3.1.13 or newer are vulnerable.
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Netatalk. Authentication is not required to exploit this vulnerability.
The specific flaw exists within the get_finderinfo method. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root.
No workarounds available
- Disable affected AFP shares until upgrade is possible
- Upgrade to TrueNAS 12.0-U8.1